AATiS AS296 Modem mit Xastir unter Ubuntu Linux

Schon seit längerem habe ich hier das Packet Radio Modem AS296 vom AATiS e.V. liegen. Leider hatte ich nie Erfolg das Modem unter Ubuntu Linux zum laufen zu bekommen. Das Problem war immer der fehlende Support für ein Pseudo-Terminal. Doch bei ubuntuusers.de habe ich die Lösung gefunden.

Nachdem diese Schritte durchgeführt sind und der Rechner neu gebootet wurde kann es man mit folgendem Befehl überprüfen:

ls -l /dev/ptypb
crw-rw-rw- 1 root tty 2, 11 Mai 18 17:49 /dev/ptypb

Nun laden wir uns das aktuelle Installations-Paket für das Modem und entpacken es

mkdir src
cd src
wget http://wiki.dl2nd.de/lib/exe/fetch.php?media=software:aatis-modem-0.2.0.zip -O aatis-modem-0.2.0.zip
unzip aatis-modem-0.2.0.zip
cd aatis-modem-0.2.0
sudo cp aatis-modem /etc/init.d/
sudo cp aatis-modem.default /etc/default/aatis-modem
sudo cp usb-as296-to-tty-d /usr/sbin/

Jetzt müssen wir in der Datei /etc/ax25/axports einen Port mit unserem Rufzeichen anlegen. Die Datei sollte nach dem Bearbeiten mit z.B. nano etwa so aussehen:

# /etc/ax25/axports
#
# The format of this file is:
#
# name callsign speed paclen window description
#
ax0 DL1MX 9600 255 7 Packet Radio

Achtung! Die Geschwindigkeit ist die für die Kommunikation mit dem Modem und nicht die Packet Radio Geschwindigkeit.

Auch die Datei /etc/default/aatis-modem muss angepasst werden. Der Parameter PTTY kann auf /dev/ptypb stehen bleiben. Anzupassen ist noch die IP-Adresse, das TXDELAY und die BAUDRATE. Für APRS muss hier 1200 stehen.

Nun kann das Modem gestartet werden:

marco@desktop:~/src/aatis-modem-0.2.0$ sudo /etc/init.d/aatis-modem start
Starting AAtis Modemattach pseudotty to ax25-kernel
AS296 Modem driver - Version: 0.2.0
selected mode 1200
set txdelay 150 ms
use persistence 255
use slottime 100 ms
use DAMA parameter
use pseudotty /dev/ptypb
AX.25 port ax0 bound to device ax0
found Modem

Okay, der port ax0 ist nun für uns verfügbar. Jetzt muss nur noch Xastir gestartet werden und konfiguriert werden. Das sieht bei mir so aus: Konfiguration von Rufzeichen, Position, Symbol und KommentarAuswahl Modemtyp Konfiguration des Ports

Kommentar schreiben

5 Kommentare.

  1. Lbr OM Marco,
    herzlichen dank für die Anleitung!!
    Leider gelingt es mir nicht, aatis-modem-0.2.0 auszupacken.
    (end-of-central-directory not found, cannot find zipfile directory … and period)
    Wenn es keine zu große Mühe macht würde ich mich freuen,
    wenn Sie mir das ZIP-File schicken könnten!
    Schöne Adventszeit und 73! Peter DJ2AX

    • Hallo Peter,
      habe es gerade auf meine Raspberry ausprobiert und den Fehler gefunden. Das -o beim wget muss groß geschrieben werden 😉 Habe im Text geändert.
      Gruß
      Marco

  2. Hallo OM Marco,

    habe nach langer Zeit wieder mal mein AS296 unter Linux (Ubuntu) in Betrieb nehmen wollen und bin auf Deine Seiten gestoßen. Leider funktioniert der Link http://wiki.dl2nd.de/lib/exe/fetch.php?media=software:aatis-modem-0.2.0.zip nicht mehr und auch der http://www.tu-chemnitz.de/stud/freizeit/amateurfunk/as296/ führt ins Leere. Hast Du ggf. noch eine funktionierende Quelle für den Treiber?

    vy 73 de Wolfgang – DM2FCO

    • Hallo Wolfgang,
      ich habe die Datei mal auf meinen Webspace gelegt:
      http://www.kubonweb.de/download/aatis-modem-0.2.0.zip
      73, Marco

      • Hallo Marco,

        ist habe mir die SW auch von deiner Seite gezogen. Allerdings hatte/habe ich einige Probleme damit.
        Ein Problem evtl. für dich als Info. Die Pseudoterminals werden in der Form /dev/ptyxx bei aktuellen Systemen nicht mehr ohne weiteres unterstützt. Aktuell werden die Pseudoterminal Multiplexer genutzt (/dev/ptmx). Wenn man unbedingt die BSD-Variante benötigt, dann muss der Kernel neu kompiliert werden.

        Aber jetzt mein eigentliches Problem. Ich nutze das AS296 Modem zusammen mit einem Yaesu FT-8800, was unter Windows ohne Probleme funktioniert, aber unter Linux (Debian 9 oder 8.7) leider nicht so richtig. Der Empfang klappt aber der Sendeimpuls ist so kurz, dass der 8800 das teilweise kaum merkt.
        Ich habe leider keine Ahnung was der Grund dafür sein könnte. Bei einem TS2000 mit eingebauten TNC im Kissmodus hat es geklappt. Daher sollte meine Linux AX25 Konfiguration nicht das Problem sein.
        Hast Du auch ein ähnliches Problem bei dir feststellen können?

        73 de DO1PWJ (Peter)

Kommentar schreiben


Hinweis - Du kannst dies benutzenHTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>